How can I turn on echo cancellation with multiple devices in Solus?

Hello everyone, new Solus user here. *waves*

 

How my current situation looks like…

I have 2 audio devices connected to the computer:

  1. Speakers (5.1), connected via aux inputs on my motherboard.
  2. Headphones with Microphone, both connected via one USB port.

And those are my audio devices listed inĀ aplay -l

  • card 0: MID [HDA Intel MID], device 0: ALC889 Analog [ALC889 Analog]
  • card 0: MID [HDA Intel MID], device 3: ALC889 Digital [ALC889 Digital]
  • (card 1 is HDMI audio output that I don’t use at all so I removed it from the list)
  • card 2: Headset [Logitech USB Headset], device 0: USB Audio [USB Audio]

My current pulseaudio version checked with pulseaudio –version command is: pulseaudio 11.1-rebootstrapped

 

What I have tried doing so far…

What I want to achieve is to cancel out audio coming out from my speakers so my microphone doesn’t capture it. I was already trying to use pactl load-module module-echo-cancel command in my terminal but all it does it display some number that gets higher each time I execute this command (I guess it’s some kind of ID of new virtual device created for echo cancellation, but might be wrong) and it adds new output and input device in Sound Settings. I was trying to play around with those settings by changing default input/output devices in there but none of those were effective so I assumed that maybe I need to do something more to get it working with multiple devices.

 

So the question is…

How can I make my echo cancellation work between my Card 2 (USB Headset) Microphone and Card 0 Speaker (5.1)?

Level 1 Asked on December 29, 2017 in General.
Add Comment
0 Answer(s)

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.